Dashboard – Degraded Performance

Incident Report for Pantheon Operations

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 15:26 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 14:23 PDT

Investigating

We are investigating reports of degraded performance affecting the Dashboard interface.
A subset of users may experience slow loading times or intermittent issues loading site environments. Live hosted sites and environment uptime are fully operational and unaffected.
Our Engineering team is actively working to identify the root cause and restore normal functionality.

Need Immediate Assistance?
General concerns: Submit a support ticket or reach out via Live Chat.
If the Dashboard is inaccessible: Contact us directly at helpdesk@pantheon.io.

We will provide another update within 30–60 minutes, or as soon as new information becomes available.
Posted Aug 20, 2026 - 14:16 PDT
This incident affected: Dashboard.