Our Engineering team has identified the root cause of the degraded performance impacting the Dashboard, Workflow, and Terminus Operations. We are currently running a necessary backend process to resolve the issue, which will take some time to complete.
Live hosted sites and uptime remain fully operational and unaffected. We will provide our next update in 2 to 3 hours, or sooner if the situation changes.
Posted Aug 04, 2026 - 14:12 PDT
Update
We are continuing to investigate this issue.
We have also received reports of degraded performance impacting Terminus Operations, which our Engineering team is now looking into alongside the Dashboard and Workflow issues. Live hosted sites and uptime remain fully operational and unaffected. We will provide another update as soon as more information becomes available.
Posted Aug 04, 2026 - 11:44 PDT
Investigating
Our internal monitoring has detected elevated error rates impacting Dashboard performance. A subset of users may experience degraded responsiveness or issues loading site environments. Live hosted sites and uptime remain fully operational and unaffected.
Our Engineering team is actively investigating the issue to restore full functionality as quickly as possible. Need Immediate Assistance?
General concerns: Submit a ticket or reach out via Live Chat. - If the Dashboard is inaccessible: Contact us directly at helpdesk@pantheon.io. - We will provide another update within 30–60 minutes, or as soon as new information becomes available.
Thank you for your patience.
Posted Aug 04, 2026 - 11:37 PDT
This incident affects: Dashboard, Workflow Operations, and Terminus Operations.